I was trying to backup my linux box (ext4) into an external NTFS HDD using rsync I got some failure errors and then I deleted the backup on External HDD using "rm -r" & "rm -rf" which was not able to delete all files/DIRs and there was some weird sounds coming out of HDD after this process (even if it was not mounted {Yes, I could still mount it} ) this happend couple of times (re-backup and delete again) then I pluged the device into an MS-Windows and tried "chkdsk /f" which fixed the sound issue and created some folders/files named "found.000 to found.999" (I was not able to see them on windows even with the hidden option enabled) it was somehow a recovey of what I had tried to get rid of with rm -rf and at the end I decided to remove all found.000-999 folders using on linux with rm -rf.
Now neither on windows nor on linux Im not able to mount it, I can see the device using diskmgmt.msc on windows and using lsblk/fdisk on linux before the disaster it was an one partition HDD now its divided to 4-5!
However Its VERY IMPORTANT/VITAL to save the data
Here is some output
# fdisk -l /dev/sdc
Disk /dev/sdc: 1.8 TiB, 2000365289472 bytes, 3906963456 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x6e697373
Device Boot Start End Sectors Size Id Type
/dev/sdc1 ? 1936269394 3772285809 1836016416 875.5G 4f QNX4.x 3rd part
/dev/sdc2 ? 1917848077 2462285169 544437093 259.6G 73 unknown
/dev/sdc3 ? 1818575915 2362751050 544175136 259.5G 2b unknown
/dev/sdc4 ? 2844524554 2844579527 54974 26.9M 61 SpeedStor
Partition table entries are not in disk order.
,
# ntfsfix -d /dev/sdc
Mounting volume... ntfs_mst_post_read_fixup_warn: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Record 0 has no FILE magic (0x0)
Failed to load $MFT: Input/output error
FAILED
Attempting to correct errors... ntfs_mst_post_read_fixup_warn: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Record 0 has no FILE magic (0x0)
Failed to load $MFT: Input/output error
FAILED
Failed to startup volume: Input/output error
Checking for self-located MFT segment... ntfs_mst_post_read_fixup_warn: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
OK
ntfs_mst_post_read_fixup_warn: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Record 0 has no FILE magic (0x0)
Failed to load $MFT: Input/output error
Volume is corrupt. You should run chkdsk.
THANKS
2 Answers
I/O
Input/output error
That may suggest a hardware problem with the drive and/or disk.
If there's a problem at either of those levels then it may be inadvisable to attempt repair of the file system.