Aws Dms. Endpoint Connection Fails in Replication Instance (Error: 1020912)

Aws Dms. Endpoint Connection Fails in Replication Instance (Error: 1020912)

Create an endpoint, associated with my AWS-DMS instance, to connect to an On-premises SQL Server database and the test connections fails!!!

Test Endpoint failed: Application-Status: 1020912, Application-Message: Failed to connect  Network error has occurred, Application-Detailed-Message: RetCode: SQL_ERROR  SqlState: HYT00 NativeError: 0 Message: [unixODBC][Microsoft][ODBC Driver 17 for SQL Server]Login timeout expired
2

2 Answers

make sure both use the same VPC plus security group

to use same VPC

create new subnet group under Subnet groups using same VPC for your On-premises Sql

I have this error when I was doing the databases migration cross-account.

If you have a source database in the source Account and a target database on the target Account.

First, you should setup the vpc peering connection (Note, VPC CIDR shouldn't overlapping.) Then you update the Route table for each other vpc cidr range.

Second, On the Target account, set up the source and target endpoint, replication instance. When you set up the replication instance, make sure it stays with the target endpoint VPC.

Third, update the source and target account database security group inbound rules, to allow the replication instance private IP address with the database port.

Then you should be able to test the source and target endpoint with the replication instance connection without this error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Sarah Jenkins
Author

Sarah Jenkins

Sarah Jenkins is a veteran tech journalist with over 12 years of experience covering artificial intelligence, mobile innovations, and digital ethics. Her insights have appeared in leading technology publications worldwide.