Mysql Workbench Support for Json Colums

Mysql Workbench Support for Json Colums

I have the following error in MySQL Workbench:

My settings are set to mysql 5.7 version:

How can I solve this?

3 Answers

I figured it out: the version number in the settings dialogue shown by the OP changes only the version for the live database side of the program. On the model side, each model has its own version setting under Model -> Model Options -> MySQL:

I inferred that because I created the model before I updated the version that my model retained the old version number, unchecked the inherit box, and changed the version - problem solved.

1

You looked at the right place, provided your SQL editor is from a model object, not from the SQL IDE. In the latter case the server you connect to decides what features are available.

However, JSON support has been added in 5.7.8 and hence the error checker complains if you only have a version below that (5.7 is the same as 5.7.0). We already recognized this situation and hence changed the version field from a selector to a free text field, which then allows to specify the release version as well. This change will be available with the next WB version.

2

Edit -> Preferences...

❌Not working

Model -> Model Options...

⭕Working completely

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Sarah Jenkins
Author

Sarah Jenkins

Sarah Jenkins is a veteran tech journalist with over 12 years of experience covering artificial intelligence, mobile innovations, and digital ethics. Her insights have appeared in leading technology publications worldwide.