Http/1.1 New Application Failed

Http/1.1 New Application Failed

i just moved from my old host to Godaddy, which seems to be a worst web host with no support.

i moved my asp website (written in classic asp) to the new godaddy windows hosting. but when i run the site i get the below error

HTTP/1.1 New Application Failed

this site worked perfectly with my previous host.

below is what i have in my web.config file

<?xml version="1.0"?>
<configuration>
    <system.webServer>
        <httpErrors errorMode="Detailed" />
        <asp scriptErrorSentToBrowser="true"/>
    </system.webServer>
    <system.web>
        <customErrors mode="Off"/>
        <compilation debug="true"/>
    </system.web>
</configuration>

can someone tell me why am i getting that error and how can i fix it?

any help will be appreciated.

2

2 Answers

I had the same issue moving a website from one hosting account (classic windows) to another (plesk), both on GoDaddy. After much headache troubleshooting, I managed to fix it by removing the whole <asp> tag from the web.config file;

    <!-- <asp scriptErrorSentToBrowser="true"/> -->

IIS 8 (only option in plesk) does not support this option altogether and configuring detailed error messaging is done differently using:

    <httpErrors errorMode="Detailed" existingResponse="PassThrough" />

You can find further instructions on this GoDaddy support page

1

I just encountered the same error this morning after renaming some Websites in IIS. A restart of IIS got my sites up and running again in seconds. Presumably the .config files are read on startup and 'likely' the cause of this error for me.

4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Marcus Vance
Author

Marcus Vance

Marcus Vance is a cybersecurity auditor and technology writer dedicated to educating the public about online safety, data privacy regulations, enterprise security, and emerging cyber threats.