A2Enmod Command Not Found in Apache Server Using Cpanel in Linux Vps

A2Enmod Command Not Found in Apache Server Using Cpanel in Linux Vps

after going to /etc/httpd/conf/httpd.conf and even after changing

Allow override none -> Allow override All , and then restarting the server using 

service httpd restart

and then i type the command

 a2enmod proxy

then i get an error :

bash- a2enmod command not found. . 

Can you please help me? i am getting an error in the developer tools console when i am using web-sockets and so for that i need to enable web-sockets proxy.

3

2 Answers

I had the same problem, and this answer solved my issue:

Apache2 command such as a2enmod and a2ensite no working its showing command not found in Ubuntu

Try:

sudo apt-get update
sudo apt-get install apache2 libapache2-mod-wsgi

Then,

sudo a2enmod wsgi

Then, you might also want to try sudo a2enmod instead of just a2enmod

On Debian a2enmod is located at /usr/sbin/a2enmod and sometimes /usr/sbin is not in your PATH.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Robert Thorne
Author

Robert Thorne

Robert Thorne covers electric vehicle innovations, autonomous driving systems, global mobility trends, and automotive engineering developments.