Sql Server Error 4060

Sql Server Error 4060

4060 "Server rejected the connection; Access to selected database has been denied".

How can I troubleshoot this error?

2

4 Answers

This error also occurs if the Database not exists

so make sure that there is a database with the name you provided in Catalog=MyDB

Do you have permission to access the database using the credentials that you are supplying? What provider are you trying to use? TCP/IP, Named Pipes? Has that provider been enabled? Is there a firewall in place and have you opened up the port to the client? Does this happen intermittently? If so, do you have enough licenses available when the error occurs? You might want to check the server error logs (and your client event log, too) for more information.

User credentials are ok, but user doesn't have the right to connect to the given database, you should grant him all rights needed...

1

You're most likely don't have the necessary permissions to access the database, or there isn't a database which correspond to the information you specified.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Alexander Ross
Author

Alexander Ross

Alexander Ross has covered the video game industry for a decade, writing deep dives on game design, esports tournaments, VR developments, and gaming culture.