Error in "Mlsd" Command While Connecting Ftp to Server [Closed]

Error in "Mlsd" Command While Connecting Ftp to Server [Closed]

I have a Web Hosting Server with Full Access of Settings. I am a Web Developer, so FTP is my daily use for updating a website. I am using a FTP client, After setting the server information, when i tried to connect, i recived an error while FTP client had send "MLSD" commant to server.

Here is the client LOG:

Status: Resolving address of si****.co (edited)
Status: Connecting to 74.208.***.***:21... (edited)
Status: Connection established, waiting for welcome message...
Response:   220 ProFTPD 1.3.3e Server (ProFTPD) [74.208.***.***] (edited)
Command:    USER si***** (edited)
Response:   331 Password required for si*****
Command:    PASS ********
Response:   230 User si***** logged in
Command:    SYST
Response:   215 UNIX Type: L8
Command:    FEAT
Response:   211-Features:
Response:    MDTM
Response:    MFMT
Response:    TVFS
Response:    UTF8
Response:    MFF modify;UNIX.group;UNIX.mode;
Response:    MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;
Response:    LANG en-US*;fr-FR;it-IT;ja-JP;ko-KR;ru-RU;zh-CN;zh-TW;bg-BG
Response:    REST STREAM
Response:    SIZE
Response:   211 End
Command:    OPTS UTF8 ON
Response:   200 UTF8 set to on
Status: Connected
Status: Retrieving directory listing...
Command:    PWD
Response:   257 "/" is the current directory
Command:    TYPE I
Response:   200 Type set to I
Command:    PASV
Response:   227 Entering Passive Mode (74,208,*,*,149,88).
Command:    MLSD
Error:  Connection timed out
Error:  Failed to retrieve directory listing

I don't know what is going wrong. My other FTP accounts for different servers is working good on the same FTP Client Software..

1

5 Answers

I've recently stumbled upon this issue too. I found none of the solutions I found within the first Google searches to be of no use, but luckily found a solution of my own...

In Site Manager change Encryption to "Only use plain FTP", mine were previously "Use explicit FTP over TLS if available".

FYI, the previous fixes I tried were:

  • Firewall configuration on the router - not possible due to work network and found is was only my PC.
  • Change something on Remote server to do with ports - Again, not possible and was only my PC having the fault.
  • Switching Filezilla from Passive to Active - Didn't work
  • Using SSH instead - rejected
3

There are two solutions to this problem

  1. change transfer mode from default to active

  2. Use SFTP - SSH file transfer Protocol.

Both are done in site manger window. I am using the latest version of FileZilla Client with Windows 10. Changing both of these did NOT solve my problem!

0

This issue is caused by firewall blocks passive connection port range where pure-ftp deamon listens

This issue can be resolved by adding passive port range in pro-ftpd.conf file as shown below

PassivePorts 60000 62000

Make sure mentioned passive port range is opened in TCP_IN of firewall allowed incoming ports

1

Check your ftp config file, there uncomment and allow to use passive ports 30000 thru 35000.

pasv_min_port=30000
pasv_max_port=35000

Also add these ports range to your firewall TCP_IN and TCP_OUT (30000:35000).

1

I had same error when I using FileZilla on ubuntu. I get rid of the error by the following steps: 1. on FileZilla, open the top tab "Site Manager" page, on top right, select the "Transfer Settings" tab. 2. On "Transfer Settings" page, there are three Transfer mode: "Default", "Active", and "Passive". Select "Active". 3. Try to connect again.

Maya Lin-Takahashi
Author

Maya Lin-Takahashi

Maya is a hardware enthusiast who tests and reviews smart home devices, smartphones, wearables, and audio gear. She focuses on practical consumer value and build quality.