I want to use docker compose with the host network.
I have a docker container that access a local REST api. Usually I run
docker run --net=host -p 18080:8080 -t -i containera
which can access the host REST api which runs at . Since I want to scale the container containera I found docker compose to scale the container. But the docker compose file from the documentation does not work. The docker container does not query the REST API.
I tried the following compose file but the property
version: "3"
services:
web:
image: conatinera:latest
network_mode: "host"
deploy:
replicas: 1
resources:
limits:
cpus: "0.5"
memory: 4G
restart_policy:
condition: on-failure
ports:
- "18080:8080"
but the property network_mode is ignored/not allowed. with the message
Ignoring unsupported options: network_mode
7 Answers
The equivalent configuration for docker-compose v3 is using the network_mode key:
You should set network_mode to "host" in your docker-compose.yml.
If using docker swarm, see codestation's answer.
You are mixing options that are invalid on either compose and swarm deployments.
If you are deploying with docker-compose up then your compose file should be like this:
version: "3"
services:
web:
image: conatinera:latest
network_mode: "host"
restart: on-failure
Te options deploy is ignored on compose mode and the ports option is ignored when using host mode networking. I recommend to don't use host mode networking and use a reverse proxy in another container to balance your scaled containers.
(Feel free to ignore this part of the answer as you clarified that you aren't using swarm deployments).
If you are using swarm deployment then your compose file should be like this:
version: "3.4"
services:
web:
image: conatinera:latest
deploy:
replicas: 1
resources:
limits:
cpus: "0.5"
memory: 4G
restart_policy:
condition: on-failure
networks:
- host
networks:
host:
name: host
external: true
Again, published ports and host mode networking do not mix. Also is probably that your scaling will fail because all the containers will try to bind to the same port. I recommend to don't use host mode networking and let docker load balance your replicas.
I was facing the same problem. I found that when network_mode is set to host, port mapping doesn't work as the container will look for the port of the host. So, removing the port mapping worked for me like the following.
services:
web-abc:
build: ./abc
# ports:
# - "7000:7000"
volumes:
- .:/code
network_mode: host
Which platform you are on? host mode is working in Linux only AFAIK. If network_mode is not working try network: host?
version: '3.4'
serivces:
some_service:
build:
network: host
i think you should define the docker-compose file like this: This is just an example, please read the docuementation:
version: "3"
services:
web:
image: conatinera:latest
networks:
mynetwork: {}
deploy:
replicas: 1
resources:
limits:
cpus: "0.5"
memory: 4G
restart_policy:
condition: on-failure
ports:
- "18080:8080"
networks:
mynetwork:
external: true
name: host
network_mode: host is not allowed in swarm mode.
I myself did not have success with networks or network_mode, but if you want to access a network service on the host, you can simply have the host service listen on the docker0 network interface, which is accessible from the container (depending on your network mode) at the same ip address. Proof of concept below.
On the host:
$ ip -4 a | grep docker0
4: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default
inet 172.17.0.1/16 brd 172.17.255.255 scope global docker0
$ echo hello world | nc -l -p 8888 -s 172.17.0.1
On the container:
$ docker run --rm -it alpine nc -w1 172.17.0.1 8888
hello world
Another way to make a host service accessible to a docker container is to listen on a unix socket, which can be mounted in the container.